Issue Details (XML | Word | Printable)

Key: PCC-106
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: Altamiranus
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
pcc

PCC doesn't recognize #include_next in GCC compat mode

Created: 29/Dec/09 10:30 PM   Updated: 31/Dec/09 12:47 PM
Component/s: C preprocessor
Affects Version/s: None
Fix Version/s: None

Environment:
Ubuntu 9.10 i386
GCC 4.4.1


 Description  « Hide
The following is defined in /usr/include/limits.h:

123:#if defined __GNUC__ && !defined _GCC_LIMITS_H_
124:/* `_GCC_LIMITS_H_' is what GCC's file defines. */
125:# include_next <limits.h>
126:#endif

Both conditions are true when GCC compatibility is enabled. However, pcc's preprocessor doesn't understand #include_next.

 All   Comments   Change History      Sort Order: Ascending order - Click to sort in descending order
Anders Magnusson added a comment - 31/Dec/09 12:47 PM
Now implemented.