Issue Details (XML | Word | Printable)

Key: PCC-163
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: Detlef Riekenberg
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
pcc

regression: libxml/parser.h is not detected by autoconf (compiler error: usednodes == 3, inlnodecnt 0)

Created: 28/Jun/10 07:40 PM   Updated: 26/Feb/11 03:49 PM
Component/s: None
Affects Version/s: None
Fix Version/s: None

File Attachments: 1. File parser.c (0.1 kB)
2. File parser_pcc-E.c (187 kB)

Environment: ubuntu 10.04 / i386


 Description  « Hide
The configure script in Wine failed to detect libxml/parser.h with CC=pcc

Result for the attached example:
/libxml_parser$ pcc -I/usr/include/libxml2 -c parser.c
parser.c, line 8: compiler error: usednodes == 3, inlnodecnt 0

A preprocessed version for the example is attached:
_scrap/libxml_parser$ pcc -I/usr/include/libxml2 -c parser_pcc-E.c
parser_pcc-E.c, line 14233: compiler error: usednodes == 3, inlnodecnt 0

gcc compiles both files

--
By by ... Detlef





 All   Comments   Change History      Sort Order: Ascending order - Click to sort in descending order
Detlef Riekenberg added a comment - 28/Jun/10 07:44 PM
The configure script detected libxml/parser.h during my last try (24.jun)

--
By by ... Detlef


Anders Magnusson added a comment - 12/Aug/10 08:27 AM
This seems to work now. Can you recheck with the latest sources?

Detlef Riekenberg added a comment - 19/Aug/10 12:41 AM - edited
Fixed for this location, Thanks ...

... but the failure is alive, when compiling tools/widl/*

/tools/widl/typetree.h, line 57: warning: illegal combination of pointer and integer
tools/widl/typetree.h, line 265: compiler error: usednodes == 5076, inlnodecnt 5075

workarounds for other bugs are needed.
See: http://wiki.winehq.org/pcc

--
By by ... Detlef

Detlef Riekenberg added a comment - 23/Feb/11 05:26 AM
This failure message is gone, but compiling widl produce broken code.
(see bug http://pcc.ludd.ltu.se/jira/browse/PCC-253)

--
By by ... Detlef

Anders Magnusson added a comment - 26/Feb/11 03:49 PM
Closed as the requestor says the problem is gone.