Issue Details (XML | Word | Printable)

Key: PCC-167
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Anders Magnusson
Reporter: Detlef Riekenberg
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
pcc

mpg123.h not detected by autoconf with pcc (error: pushback buffer full)

Created: 25/Aug/10 06:05 PM   Updated: 25/Nov/10 11:03 PM
Component/s: C preprocessor
Affects Version/s: None
Fix Version/s: None

File Attachments: 1. File mpg123.c (2 kB)

Environment: ubuntu 10.04/i386


 Description  « Hide
The Wine configure script failed to detect <mpg123.h>, when using pcc
(preprocesor)

Result for the attached example:
_scrap/mpg123$ pcc -E mpg123.c -o mpg123_pcc-E.c
/usr/include//mpg123.h:428: error: pushback buffer full

--
By b y ... Detlef


 All   Comments   Change History      Sort Order: Ascending order - Click to sort in descending order
Detlef Riekenberg added a comment - 25/Aug/10 06:18 PM - edited
Increasing NAMEMAX to 512000 does not help
(but 1024000 works)

--
By by ... Detlef



Index: cc/cpp/cpp.h
===================================================================
RCS file: /cvsroot/pcc/cc/cpp/cpp.h,v
retrieving revision 1.43
diff -u -r1.43 cpp.h
--- cc/cpp/cpp.h 25 Feb 2010 15:49:00 -0000 1.43
+++ cc/cpp/cpp.h 25 Aug 2010 16:16:22 -0000
@@ -65,7 +65,7 @@
 #endif
 #endif
 
-#define NAMEMAX CPPBUF /* currently pushbackbuffer */
+#define NAMEMAX 1024000 /* currently pushbackbuffer */
 
 /* definition for include file info */
 struct includ {


Anders Magnusson made changes - 31/Aug/10 09:47 PM
Field Original Value New Value
Assignee Anders Magnusson [ ragge ]
Anders Magnusson added a comment - 31/Aug/10 09:48 PM
Hm, I fail to reproduce this...?

Anders Magnusson added a comment - 07/Nov/10 11:57 AM
This may be fixed now, can you please recheck?

Anders Magnusson added a comment - 25/Nov/10 06:55 PM
Closed due to no response.

Anders Magnusson made changes - 25/Nov/10 06:55 PM
Status Open [ 1 ] Closed [ 6 ]
Resolution Fixed [ 1 ]
Detlef Riekenberg added a comment - 25/Nov/10 11:03 PM
This works now.
Thanks
--
By by ... Detlef