Issue Details (XML | Word | Printable)

Key: PCC-276
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Anders Magnusson
Reporter: Richard Spencer
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
pcc

Cross-compile to target i386-pe (win32) fails to build

Created: 15/Mar/11 07:29 PM   Updated: 19/Apr/11 10:11 PM
Component/s: Common code, i386 target
Affects Version/s: None
Fix Version/s: None

Environment: Linux Fedora Core 11


 Description  « Hide
After "configure --target=i386-pe" the build fails at file ../arch/i386/local.c with issue over undefined macro MKSUE(). Looking at the code (line 121) this is just after an "#ifdef os_win32" so maybe this case has been neglected during a code change?

Failure occurs with "make CC=pcc" or gcc and binutils 2.18 and 2.20.1 and version pcc-1.0.0.BETA-20110314, at the same place. Happy to assist with testing a fix but don't think I'm able to fix the code myself.

 All   Comments   Change History      Sort Order: Descending order - Click to sort in ascending order
Anders Magnusson added a comment - 19/Apr/11 10:11 PM
Whatever you want, now it's closed :-)
I think the intention from the writer of the bugtracker is that a requestor should close the bug report when he has confirmed that the resolved bug is fixed. Not that I have cared about it, though... :-)

Richard Spencer added a comment - 19/Apr/11 10:00 PM
I realise it seems to be out of fashion for this Project, but I'm happy for this issue to be marked Closed. Many thanks.

Richard Spencer added a comment - 31/Mar/11 09:45 PM
Excellent!! I have now successfully compiled, linked and run (under Windows) a PCC program. If you're interested I could have a go at writing a HOWTO? (I have made a bit of a mess of my /usr/local in the process so want to see if --with-prefix= etc. can lessen the pain of building PCC as a cross compiler.)

Also, I notice on the TODO page the intention to look at '#pragma' - I had to build the Windows link-libraries using gcc because PCC complains; it would be great if this could be fixed too. Many thanks again for solving this issue.

Anders Magnusson added a comment - 30/Mar/11 06:36 PM
Eh, I fixed that also yesterday but forgot to pullup it to 1.0. Fixed now, thanks.

Richard Spencer added a comment - 30/Mar/11 06:21 PM
Thanks for looking into this. Problem still occurs here I'm afraid with beta 20110330. Now I get: "../../arch/i386/local.c, line 122: member 'n_sue' not declared" (same file) and compilation stops.

PS. Not sure if I can reopen this issue or need to create a new report?

Anders Magnusson added a comment - 27/Mar/11 09:20 PM
FIxed now, thanks.