Issue Details (XML | Word | Printable)

Key: PCC-310
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Anders Magnusson
Reporter: Fred J. Tydeman
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
pcc

signgam is in user's name space

Created: 12/Apr/11 09:30 PM   Updated: 13/Apr/11 06:12 PM
Component/s: None
Affects Version/s: None
Fix Version/s: None

Environment: Intel Core it (64-bit); Linux Fedora Core 14 (64-bit); pcc 1.0.0 of 2011/02/21


 Description  « Hide
Code similar to

#include <math.h>
char signgam[] = "deadbeef";
int main(void){
   double d = lgamma(1.5);
  return 'e' == signgam[1];
}

gets many errors. The problem is, signgam is the sign of gamma to some
lgamma() functions and violates the user's name space.

 All   Comments   Change History      Sort Order: Ascending order - Click to sort in descending order
Anders Magnusson made changes - 13/Apr/11 06:11 PM
Field Original Value New Value
Assignee Anders Magnusson [ ragge ]
Anders Magnusson added a comment - 13/Apr/11 06:12 PM
The math.h header file is property of the system (fedora) and not the compiler, so there is actually nothing that can be done about this in the compiler. Sorry.

Anders Magnusson made changes - 13/Apr/11 06:12 PM
Status Open [ 1 ] Closed [ 6 ]
Resolution Fixed [ 1 ]