Issue Details (XML | Word | Printable)

Key: PCC-59
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: Jonathan Gray
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
pcc

ICE compiling machdep.c

Created: 04/Jun/09 06:02 AM   Updated: 12/Sep/09 09:18 AM
Component/s: None
Affects Version/s: None
Fix Version/s: None

Environment: OpenBSD/i386 -current with pcc cvs


 Description  « Hide
pcc -Wall -Wstrict-prototypes -Wmissing-prototypes -Wno-uninitialized -Wno-format -Wno-main -Wstack-larger-than-2047 -fno-builtin-printf -fno-builtin-log -O2 -pipe -nostdinc -I. -I../../../.. -I../../../../arch -DDDB -DDIAGNOSTIC -DKTRACE -DACCOUNTING -DKMEMSTATS -DPTRACE -DCRYPTO -DSYSVMSG -DSYSVSEM -DSYSVSHM -DUVM_SWAP_ENCRYPT -DCOMPAT_43 -DCOMPAT_O43 -DLKM -DFFS -DFFS2 -DFFS_SOFTUPDATES -DUFS_DIRHASH -DQUOTA -DEXT2FS -DMFS -DNNPFS -DTCP_SACK -DTCP_ECN -DTCP_SIGNATURE -DNFSCLIENT -DNFSSERVER -DCD9660 -DUDF -DMSDOSFS -DFIFO -DINET -DALTQ -DINET6 -DIPSEC -DPPP_BSDCOMP -DPPP_DEFLATE -DMROUTING -DBOOT_CONFIG -DUSER_PCICONF -DKVM86 -DUSER_LDT -DAPERTURE -DCOMPAT_SVR4 -DCOMPAT_IBCS2 -DCOMPAT_LINUX -DCOMPAT_FREEBSD -DCOMPAT_BSDOS -DCOMPAT_AOUT -DPROCFS -DPCIVERBOSE -DEISAVERBOSE -DUSBVERBOSE -DPCMCIAVERBOSE -DPCMCIADEBUG -DWSDISPLAY_COMPAT_USL -DWSDISPLAY_COMPAT_RAWKBD -DWSDISPLAY_DEFAULTSCREENS="6" -DWSDISPLAY_COMPAT_PCVT -DONEWIREVERBOSE -DMULTIPROCESSOR -D_KERNEL -Di386 -c ../../../../arch/i386/i386/machdep.c
../../../../arch/i386/i386/machdep.c, line 462: compiler error: internal label 2742 not defined

 All   Comments   Change History      Sort Order: Descending order - Click to sort in ascending order
Anders Magnusson added a comment - 12/Sep/09 09:18 AM
On request closed.

Jonathan Gray added a comment - 05/Sep/09 12:04 PM
Fixed, kindly close.

Jonathan Gray added a comment - 08/Aug/09 06:09 PM
Still occurs with -O0

Jonathan Gray added a comment - 08/Aug/09 03:50 PM
But now it seems to make real machines and qemu triple fault/reboot. Sounds like some bad code is being generated.

Jonathan Gray added a comment - 08/Aug/09 10:54 AM
This seems to be resolved indeed. machdep.c now compiles without issue here.

Anders Magnusson added a comment - 08/Aug/09 10:01 AM
I cannot reproduce the error on the preprocessed file, can you?

Jonathan Gray added a comment - 04/Jun/09 09:34 PM
preprocessed file can be found at:
http://goblin.cx/misc/machdep.c

Jonathan Gray added a comment - 04/Jun/09 08:26 AM
I can't attach a file with the preprocessed output to this as it keeps timing out...