Issue Details (XML | Word | Printable)

Key: PCC-75
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Blocker Blocker
Assignee: Gregory McGarry
Reporter: Detlef Riekenberg
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
pcc

Startfiles crt*.o missing in an out of tree build

Created: 10/Aug/09 09:22 PM   Updated: 20/Aug/09 11:44 PM
Component/s: i386 target
Affects Version/s: None
Fix Version/s: None

File Attachments: 1. File fix regression for targets without a subdir in csu.diff (0.5 kB)

Environment: i386 linux (UBUNTU 9.04)


 Description  « Hide
When building pcc-libs out of the source tree, no startfiles are build
and pcc failed then to create a executable.

Example: <pcc-libs>/csu/linux/crtbegin.o

--
By by ... Detlef



 All   Comments   Change History      Sort Order: Ascending order - Click to sort in descending order
Gregory McGarry added a comment - 10/Aug/09 11:51 PM
It works for me on Ubuntu 8.04.

Can you provide more information? Maybe a log of what you're doing? The actual failure?

Detlef Riekenberg added a comment - 11/Aug/09 05:37 PM
if test -d linux ; then cd linux && make -w CC=pcc MACH=i386 PCCLIBDIR=/usr/local/lib/pcc/i686-pc-linux-gnu/0.9.9/lib all; fi

This can't work on any system, when using an out of tree build.

To reproduce:
----------
cd <where you want>
cvs -d :pserver:anonymous@pcc.ludd.ltu.se:/cvsroot co pcc-libs
mkdir libs.bin
cd libs.bin
../pcc-libs/configure --verbose
make
-----------
There is no failure message.
<where you want>/pcc-libs.bin/csu/linux is not created and no startfiles where build.

Do you have a different source tree location?

--
By by ... Detlef

Gregory McGarry added a comment - 11/Aug/09 11:47 PM
Ah, I understand.

I guess there are some variables which should be honoured in the csu directories.

Gregory McGarry added a comment - 13/Aug/09 11:17 AM
I think I fixed the problem with some sprinkling of @srcdir@ and VPATH. Only tested on OS X.


Detlef Riekenberg added a comment - 13/Aug/09 08:21 PM
The previous mentioned commit fixed the compilation on linux,
but broked the build for all systems without a subdir in <pcc-libs>/csu
(win32 as example)

A fix for the new regression is attached.

--
By by ... Detlef


Gregory McGarry added a comment - 14/Aug/09 04:28 AM
Thanks! I've committed the change.

Detlef Riekenberg added a comment - 20/Aug/09 07:28 PM
This BUG can be closed.

--
By by ... Detlef