Back to wiki

RCS History

/ TOP / supported-platforms.mdwn

Differences for revision 1.4 from 1.3


--- supported-platforms.mdwn	2008/04/12 13:42:06	1.3
+++ supported-platforms.mdwn	2008/06/05 07:02:10	1.4
@@ -1,5 +1,21 @@
 The following list describes steps to make PCC the system compiler.
 
+__Debian GNU/Linux 4.0r0__
+
+You must build and install the pcc-libs module which contains libpcc.a and stddef.h header files.
+
+__SuSE Linux Ent Svr 10__
+
+You must build and install the pcc-libs module which contains libpcc.a and stddef.h header files.
+
+__Mandriva Corporate Server 4.0__
+
+You must build and install the pcc-libs module which contains libpcc.a and stddef.h header files.
+
+__Red Hat Ent Linux 5__
+
+You must build and install the pcc-libs module which contains libpcc.a and stddef.h header files.
+
 __NetBSD 4.0 (i386/mips/arm/powerpc)__
 
 NetBSD 4.0 needs at least this change:
@@ -101,6 +117,8 @@
 
 __Mac OS X 10.4 (powerpc)__
 
+You must build and install the pcc-libs module which contains libpcc.a
+
 Many OS X header files use the preprocessor directive #pragma pack(), which isn't supported by PCC.  Ignore the warning for the moment and hope that it doesn't matter too much.
 
 Additionally, stdargs.h only works with gcc.  Paste the following lines into /usr/local/lib/pcc/stdarg.h:
@@ -118,7 +136,12 @@
 
     #endif
 
-__Debian__
+__Mac OS X 10.5 (powerpc)__
+
+You must build and install the pcc-libs module which contains libpcc.a.
+
+Some of the issues may apply from OS X 10.4 discussed above.
 
-There have been reports that Debian header files depend on gcc.  No patches have been supplied yet.
+__Mac OS X 10.5 (intel)__
 
+Unsupported until changes are brought over from powerpc.
\ No newline at end of file

Powered by rcshistory.cgi 0.3